DP - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 23:00 EST

Investigating

A portion of the site went down due to an electrical issue.

A tech will be on the way Monday to help fix the situation.
Posted Nov 16, 2025 - 14:00 EST
This incident affected: TX - DP.