LF - Internet Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 19:00 EST

Investigating

The primary internet is down in the area.

Techs will be on site to bring everything back after the outage.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Feb 20, 2026 - 15:06 EST
This incident affected: KY - LF.