DP - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 12:50 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 10, 2025 - 09:45 EST

Identified

A portion of the site is currently down due to an electrical issue.

A technician will be on site Monday to fix this.
Posted Nov 07, 2025 - 20:00 EST
This incident affected: TX - DP.