RH - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 20:36 EDT

Investigating

The power is currently down in the area. No ETA for now.

Techs will be on site to bring everything back after the outage.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Apr 02, 2025 - 15:13 EDT
This incident affected: KY - RH.