LF - Electrical Outage
Incident Report for Blockware Solutions
Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 11:26 EST
Investigating
We have a section of the site that went down due to an electrical issue. This affects around 25% of the site.

We will follow up here with investigation details.
Posted Nov 21, 2024 - 23:54 EST
This incident affected: KY - LF.