DP - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 05:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.

A portion of the site is still down due to a pump failure.
Posted Mar 14, 2025 - 20:00 EDT

Identified

The power is currently down in the area due to abnormal weather conditions. Estimated 2 to 3 hours to restore.

Techs will be on site to bring everything back after the outage.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Mar 14, 2025 - 10:05 EDT
This incident affected: TX - DP (Hydro).