Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 14:00 EDT
Scheduled
The sites will be down from 2PM to 7PM EST due to a curtailment in the area. The end time is an estimate but most curtailments have been between 3 and 4 hour long.
Techs will be on site to bring everything back after the curtailment.
For any questions or concerns, please open a support ticket and we will follow up there.
Posted Jun 23, 2025 - 12:26 EDT
This scheduled maintenance affected: KY - LF and KY - RH.