SD2 - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 11:00 EST

Investigating

The power is currently down in one can of the site. The ETA is Saturday morning as we will get an expert team on site for that matter.

Techs will be on site to bring everything back after the outage.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Mar 05, 2026 - 09:30 EST
This incident affected: TX - SD2.