DP - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 11:26 EDT

Identified

A pole in the area will need to be repaired. The ETA is about 3 business days.

Sorry for the inconveniences.
Posted Aug 14, 2025 - 11:42 EDT

Investigating

The power is currently down for a section of the site, about 1/4th of it. We currently don't have an ETA on when this will be resolved.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Aug 13, 2025 - 16:00 EDT
This incident affected: TX - DP (Hydro).