RH - Power Outage

Incident Report for Blockware Solutions

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 14:20 EDT

Investigating

The power is currently down in a section of the site. A team will be on site next Monday to identify and fix the issue.

Techs will be on site to bring everything back after the outage.

For any questions or concerns, please open a support ticket and we will follow up there.
Posted Jun 27, 2025 - 15:11 EDT
This incident affected: KY - RH.